IBM 3270 AT - Reparatur - Versuch

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • IBM 3270 AT - Reparatur - Versuch

      Hier geht es nun mal weiter mit meinem 3270 AT.

      Vorgeschichte (copy&paste):

      Eines Abends stöberte ich mal wieder in der elektronischen Bucht nach dies und das und fand doch ein schönes Gerät zur Selbstabholung. Natürlich ist es defekt. Aber gut... Defekte kann man ja beheben.
      Nun lag aber der Ort für die Selbstabholung mal 300km Weit entfernt. Das ist für mich eigentlich zu viel des Guten...

      Nunja... Aber ich wollte das Teil unbedingt haben.
      "Schatz... wollen wir nicht mal nach Augsburg Fahren? Die haben bestimmt einen schönen Zoo und die Kinder würden sich das bestimmt gerne ansehen... und da gibt es was, dass ich gerne dort abholen würde...."

      Das hat funktioniert. Also Gekauft und gestern (16.8.2016) ging es nach Augsburg.

      Die Hinfahrt:

      Horror... 1Stunde 45Minuten totaler stillstand auf der A8. Ganz toll mit 3 kleinen Kindern im Auto und einer etwas genervten Ehefrau... Urgs...

      Der Zoo und Augsburg:

      Der war ganz OK. Hatte mir mehr versprochen. Aber für die Kinder war es toll. Haben gut durchgehalten und alles angesehen. Das Wetter hat ja auch echt Super mitgemacht.
      Augsburg ist auch eine schöne Stadt. Kann man sich schon mal ansehen. Das hat dann die Laune meiner Frau angehoben. Und das Eiskalte gute Radler sowieso.



      Der Rechner im Ursprungszustand:



      Der Monitor war auch dabei



      Voll bestückt das gute Teil




      Und hier schon schön zu sehen: Die Batterie ist ausgelaufen... und das nicht zu knapp....







      Hier der Übeltäter:



      Große Schäden bräuchten größere und stärkerer Maßnahmen. @Beckenrand-schwimmer hat seinen Kärcher ausgepackt und das Board gereinigt. Vorher wurde natürlich alles soweit entfernt wie möglich. Dabei ist ein PIN der CPU im Sockel hängen geblieben. Der Wurde wieder angelötet:





      Nach der Kärcheraktion war das Board einigermaßen sauber, aber der Wasserdruck hat gezeigt, wo sich das "Zeugs aus der Lithiumhölle" durchgefressen hat.







    • Am Wochenende ging es nun endlich weiter. Zuerst musste Rost und Schmodder entfernt werden. Das ist in dem Gehäuse gar nicht so einfach, da man nicht viel abbauen kann. Hier wurde noch gut geschweißt und schweres Metall verwendet.





      Danach wurde erstmal das neue Mainboard eingebaut und ein allgemeiner Funktionstest gemacht.

      Ergebnis:

      5 1/4" 1.2MB Floppy - OK
      3 1/2" 720KB Floppy - Defekt
      20MB MFM Platte - zu 40% Defekt. Bootfähig
      Netzteil - OK





      Leider läuft das Board aktuell nur mit 256kb RAM, da ein Käferpärchen leider defekt ist. Und ich finde die Tüte mit den ersatz-Käferchen nicht!!! ARGH...

      So bald ich die Tüte gefunden habe, geht es weiter.
    • Ey, du machst Sachen...wie um alles in der Welt hast du den denn so sauber bekommen?
      Schweine Arbeit. Oder hast du getrickst, mit Öl-getränkten Lappen? :)

      Welche Karten waren da drin? Das sah so nach SLI aus ganz am Anfang.

      Das dieser alte HDD-Brecher überhaupt noch geht ist doch Wahnsinn.
      Oh Mann, jetzt wirst du auch so ein...na wie soll man sagen...Hardware Zauberer :super
    • struuunz schrieb:

      Der Zoo und Augsburg:

      Der war ganz OK. Hatte mir mehr versprochen. Aber für die Kinder war es toll. Haben gut durchgehalten und alles angesehen. Das Wetter hat ja auch echt Super mitgemacht.
      Augsburg ist auch eine schöne Stadt. Kann man sich schon mal ansehen. Das hat dann die Laune meiner Frau angehoben. Und das Eiskalte gute Radler sowieso.
      Super, schön wenn es dir gefallen hat, Augsburg ist für eine (kleinere) Großstadt ziemlich grün, nicht wahr ? (Zumindest im Sommer). :) Viele Parks und kleine Wäldchen.
      Der botanische Garten gleich neben dem Zoo ist im Sommer einfach göttlich, dort wartet am Ende auch ein eiskaltes Radler. :D

      Aber...

      struuunz schrieb:

      Die Hinfahrt:

      Horror... 1Stunde 45Minuten totaler stillstand auf der A8. Ganz toll mit 3 kleinen Kindern im Auto und einer etwas genervten Ehefrau... Urgs...
      ...kannst ja beim nächsten Mal Bescheid geben, dann hole ich den Rechner ab und kann ihn dir schicken.



      EDIT: Wer es nicht weit nach Augsburg hat und im März mal etwas Zeit über hat, kann ja mal einen Blick hierauf werfen:

      hs-augsburg.de/retropulsiv/RETROpulsiv/Willkommen.html
      hs-augsburg.de/retropulsiv/RETROpulsiv/RETROpulsiv_9.0.html
      (im Vortragsprogramm u.a. Herwig Solf: KCS Power PC Board – aus dem Amiga 500 wird ein Turbo XT)
    • @LoWang87: Hätte ich das gewusst... aber glaub mir. Das Teil ist extrem schwer. Da hättest du dir keinen gefallen getan beim versenden. Aber gut zu wissen, dass du in der Ecke zu Diensten stehst :)

      Ich finde die verdammte Tüte mit den RAMs nicht! ARGH! Will doch weiter bauen! Finde so ziemlich alles, nur das richtige nicht!
    • @struuunz:

      Wow, der IBM 3270 funktioniert ja. Top. Da denke ich wurden die defekten LS-Käferchen wohl alle professionell von @Beckenrand-schwimmer gewechselt, gell ?
      Super, dass das Board bzw die Traces ja kaum angegriffen wurden. Nur noch RAM und das Ding läuft. :)

      Und die Vorredner haben Recht, der Monitor hat eine perfekte Farbe.

      Immer weiter mit dem tollen Bericht bitte. Musst mir ja Konkurrenz bei meinem IBM 5170 machen :)

      Gruß
      RetroComputerPoPe - Dr. (Ehrenhalber) Darius von Bernstein - Grünstein - Lötstein - Bezwinger der EIZO ( ͡° ͜ʖ ͡° )
      Tollwütiger DOSianer mit mittlerweile jeder DOS-Architektur (XT/286/386/486/586/686...)
      Status: Don't mess with the RetroPoPe / Erweiterter Amateur mit der unoffiziellen Bräter-Lizenz *g*
    • Oh ich höre im Hintergrund ehemaliges vieles Fluchen vom Auslöten der angefressenen alten LS ICs und weiteres Fluchen für die Unversehrtheit der VIAs, ...
      Zusätzlich kommt dann das Fluchen beim Einlöten der ICs ;) Wie ich das kenne. Glaub mir so ein Euro PC Mainboard ist auch nicht ohne, ...
      RetroComputerPoPe - Dr. (Ehrenhalber) Darius von Bernstein - Grünstein - Lötstein - Bezwinger der EIZO ( ͡° ͜ʖ ͡° )
      Tollwütiger DOSianer mit mittlerweile jeder DOS-Architektur (XT/286/386/486/586/686...)
      Status: Don't mess with the RetroPoPe / Erweiterter Amateur mit der unoffiziellen Bräter-Lizenz *g*
    • Ranger85 schrieb:

      struuunz schrieb:

      mein lieber @Darius... Ich glaube der Kontrast an deinem Monitor muss mal angepasst werden
      Das verräterische Wörtchen ist aber auch fies versteckt - vor allem für die, die das Forum auf ein dunkles Thema konfiguriert haben... :mrgreen :mrgreen :mrgreen:
      Oh, vielen Dank @struuunz :mrgreen :D
      Ich glaube ich muss wirklich mal meine Gitterspannung um ein paar kV erhöhen :duck :smiley_emoticons_frankenstein_lol
      Denn was bringt denn eine Kontraständerung am Monitor, wenn die Hochspannung zu gering ist :D
      RetroComputerPoPe - Dr. (Ehrenhalber) Darius von Bernstein - Grünstein - Lötstein - Bezwinger der EIZO ( ͡° ͜ʖ ͡° )
      Tollwütiger DOSianer mit mittlerweile jeder DOS-Architektur (XT/286/386/486/586/686...)
      Status: Don't mess with the RetroPoPe / Erweiterter Amateur mit der unoffiziellen Bräter-Lizenz *g*
    • Beckenrand-schwimmer schrieb:

      Es ehrt mich allerdings schon, dass Darius mir solch eine Reparatur zutraut!
      Ach wo. Da knicke ja eher ich ja meterweit ein und hab dann Pipi in den Augen :mrgreen
      Soviel zum Thema Zutrauen
      :atomrofl
      RetroComputerPoPe - Dr. (Ehrenhalber) Darius von Bernstein - Grünstein - Lötstein - Bezwinger der EIZO ( ͡° ͜ʖ ͡° )
      Tollwütiger DOSianer mit mittlerweile jeder DOS-Architektur (XT/286/386/486/586/686...)
      Status: Don't mess with the RetroPoPe / Erweiterter Amateur mit der unoffiziellen Bräter-Lizenz *g*
    • Für Hochspannung bin ich immer zu haben ;)

      Aber mal im Ernst. Auf dem defekten Board ist richtig Schaden entstanden. Zumindest alle Chips aus Keramik hat es gehimmelt. Das PCB und die Leiterbahnen scheinen es überstanden zu haben. Aber der Quarz, ein paar Widerstandsnetzwerke und so einige Customs Chips sind wohl defekt. Ohne noch mal 30...40€ zu investieren, mit ungewissem Augang, geht da nichts mehr.
      Da war Struuunz sehr gut beraten ein funktionstüchtiges Mainboard zu bekommen. Nur das mit den Chips ist echt blöd, hab hier auch schon alles abgesucht. Also wenn hier noch irgendeiner einen 128k "Double Stacked" RAM rum fliegen hat, wäre es sehr nett diesen zum Struuunz zu bringen. :thumbsup:
    • Genau so siehts aus. Der @Beckenrand-schwimmer hatte mir ein Mainboard bei eBay gezeigt und ich habe es dann natürlich ersteigert. Die Custom-Chips bekommt man nur recht schwer und die wären dann am Ende mind. genauso teuer gewesen, wie ein komplettes und vor allem funktionierendes Board. Daher gab es auch keinen ausführlichen Reparaturbericht. Der kommt dann, wenn ich die Chips doch noch irgendwo her bekomme. :)

      Jetzt mal noch ein paar Bilder

      Zuerst wurden die RAM-Chips einzeln durchgetestet. Das Board kam voll bestückt mit 512kb an. Leider zeige es nur 256kb an. Sprich die Bank 0 Funktioniert und Bank 1 hat einen Fehler. So hat @Beckenrand-schwimmer jeden Chip aus der Bank 1 in der Bank 0 getestet. So war schnell das Chippärchen gefunden, welches nicht mehr wollte. Währenddessen habe ich das Gehäuse geschrubbt und den Rost mit Schleifpapier entfernt.



      Wie man sieht, ist die PCB-Farbe eine andere als das Original Board was in der Maschine war. Das alte war Grün und dieses hier ist dunkel Lila.





      Oben sieht man schön den freien Sockel. Da muss nur noch ein funktionierendes Pärchen rein und der IBM hat die vollen 512kb.



      Jetzt suchen wir halt die blöde Tüte von dem alten Mainboard. Da haben wir alle Chips und RAM gelagert, bevor der Kärcher zum Einsatz kam. Leider ist die verschollen... aber irgendwo muss sie ja sein und sobald sie Auftaucht geht es weiter!
    • Ja,

      da war mein Monitorkontrast wohl nicht so ganz hochgestellt bzw. die Gitterspannung dessen. Dass es bei der Kärcher-Aktion die Custom-Chips gehimmelt hat ist mir da nicht aufgefallen.
      Ein Glück, ein Austausch-Board bekommen zu haben, oh ja :Clap
      RetroComputerPoPe - Dr. (Ehrenhalber) Darius von Bernstein - Grünstein - Lötstein - Bezwinger der EIZO ( ͡° ͜ʖ ͡° )
      Tollwütiger DOSianer mit mittlerweile jeder DOS-Architektur (XT/286/386/486/586/686...)
      Status: Don't mess with the RetroPoPe / Erweiterter Amateur mit der unoffiziellen Bräter-Lizenz *g*